Thunderbird Override Add-on Compatibility Checking Issues

We described in the Thunderbird 5 Beta 1 Released post how to override Add-on Compatibility Checking by adding and setting the following Boolean entry to FALSE in Thunderbird’s about:config:

extensions.checkCompatibility.5.0b

There has been some isolated reports that after restarting Thunderbird users see the message: Add-on compatibility checking is disabled. You may have incompatible add-ons in Thunderbird’s add-on manager. However, their add-ons are stuck in a Disabled status. This is caused by Thunderbird’s extension files become corrupted. Simple fix to get your add-ons working again:

  • Close Thunderbird
  • Locate your profile folder
  • Delete the following files from your profile folder.
    Note: You may not have all these files:

    • extensions.ini
    • extensions.cache
    • extensions.rdf
    • extensions.sqlite*
  • Restart Thunderbird

* extensions.sqlite appears in Thunderbird builds on the Gecko 2.0 Platform or newer, which included Thunderbird 3.3 Alpha builds and the new Thunderbird 5.0 Beta builds.

When you restart Thunderbird it will automatically rebuilt the extensions list, replacing the files you just removed with fresh updated copies. Your add-ons should now be enabled. This method also works in Firefox as well.

4 Comments on Thunderbird Override Add-on Compatibility Checking Issues

  1. I deleted those files, yet still had to do some tweaking.

    I went into the Config Editor, and created a new false boolean value:
    extensions.checkCompatibility.5.0b

    I restarted Thunderbird and they are enabled once again. Not that they work, which is a big grrrrrrrrr (Lightning and MinimizeToTray), but at least they are enabled.

  2. I have the same issue in Thunderbird 6.0.2 were my Add-ons keep being disabled when I restart the program how do I fix that.

    Thanks

Leave a comment

Your email address will not be published.


*