Add-on Compatibility Reporter

With Thunderbird 5 due out later today, users are going to find many of their add-ons may not work. Some add-on developers may be caught off-guard by the recent progress of Thunderbird 3.3/5.0 development and were not anticipating Thunderbird 5 to be release so soon. We are seeing a lot of this on the Firefox side with the release of Firefox 5 last week.

However, unlike Firefox 4 and Firefox 5, add-ons that are working in Thunderbird 3.1 may not work in Thunderbird 5. The move from Thunderbird 3.1 to Thunderbird 5 would be like going from Firefox 3.6 to Firefox 5.0 (although the user interface change is not as dramatic). There are so core changes to Thunderbird 5.0 that may affect the way extensions work. With that said though, there is still a good chance that most of these add-ons once forced will work in Thunderbird 5.0. I know for sure on Windows these add-ons do work in Thunderbird 5.0 and beyond on their own or if forced:

  • AdBlock Plus
  • ChormEdit Plus
  • Identity Chooser
  • Nightly Tester Tools
  • Personas Plus
  • URL Link

The Add-on Compatibility Reporter will allow you to bypass the add-on compatibility checking so extensions that have not yet been updated can be installed. However, doing so is at your own risk, especially LINUX (Mint for sure) users.

Leave a comment

Your email address will not be published.


*